Is eero protected against KRACK?

Yes, eero is protected against the WPA2 security vulnerability known as KRACK.

To ensure your eero WiFi system is protected, all customers are encouraged to update their network to at least eero OS version 3.5. To check the eero OS version of your network:

  • Open the eero app
  • Tap on an eero from your home screen
  • Under eero OS version, you will see the current version number

If the version is under 3.5.0-312, do the following to update your network:

  • Tap the menu button
  • Tap Network Settings
  • Tap Update available under the Network software section

Updating your network will require your network to reboot.

For more information, please visit our blog.

Was this article helpful?

Didn't find what you're looking for?

Give us a call at (877) 659-2347 or submit a request. We’ll get back to you as soon as possible.

Powered by Zendesk